Blackboard Learn 9 Outage
Incident Report for SCSU System Status
Resolved
Blackboard is back online and fully operational.
Posted Oct 07, 2019 - 18:49 EDT
Investigating
Blackboard is currently experiencing a mass outage affecting multiple customers, including SCSU. We will provide updates as we receive them.
Posted Oct 07, 2019 - 17:57 EDT
This incident affected: Blackboard Learn 9.