Expired Cert
Incident Report for SCSU System Status
Resolved
This incident has been resolved.
Posted Aug 13, 2020 - 10:49 EDT
Update
The vendor updated the cert as of 10:30PM on 8/13/20 on helpdesk.southernct.edu. The site is confirmed to be fully functional.
Posted Aug 13, 2020 - 10:48 EDT
Investigating
The Cert for helpdesk.southernct.edu expired today, users will need to click on allow page to load when visiting the site. IT is working with Blackboard to update the cert.
Posted Aug 10, 2020 - 14:58 EDT
This incident affected: IT Help Desk.