Degree Works is currently not available
Incident Report for SCSU System Status
Postmortem

The nightly maintenance job ran longer then expected. IT will work with the vendor to see how we can prevent this from happening again.

Posted Jan 19, 2022 - 15:10 EST

Resolved
The Incident with Degree Works has been resolved.
Posted Jan 19, 2022 - 15:08 EST
Investigating
We are currently investigation why Degreeworks in not loading student data.
Posted Jan 19, 2022 - 13:48 EST
This incident affected: Degree Works.