Degree Works
Incident Report for SCSU System Status
Resolved
This issue has been resolved.
Posted Dec 09, 2022 - 09:40 EST
Investigating
We are currently investigating this issue.
Posted Dec 09, 2022 - 09:06 EST
This incident affected: Degree Works.