Self-Help Portal Degraded Experience
Incident Report for SCSU System Status
Resolved
This incident has been resolved.
Posted Jan 05, 2022 - 08:58 EST
Update
We are continuing to investigate the root cause of this issue. The Self Help Portal (helpdesk.southernct.edu) and its services are scheduled to return to fully operational status on December 20th, 2021.
Posted Dec 09, 2021 - 08:24 EST
Investigating
The Self-Help portal (Helpdesk.SouthernCT.edu) is currently experiencing technical issues with a degraded experience. Self-Help Articles are available using the search function. IT support is available via Email, Telephone, and Chat.

We will continue to monitor the status and will report updates as needed.
Posted Nov 22, 2021 - 08:48 EST
This incident affected: IT Help Desk.