Phone System Maintenence
Incident Report for SCSU System Status
Resolved
No issues have been found. All systems operational
Posted Dec 12, 2022 - 08:46 EST
Monitoring
The change to the Phone System has been implemented. We will continue to monitor throughout the weekend.
Posted Dec 09, 2022 - 11:34 EST
This incident affected: Telephone Systems.