Banner Faculty/Advising
Incident Report for SCSU System Status
Resolved
If the issue persists for you, please clear your browser cache and set the language preference setting in your browser to English USA. This should fix the issue.
Posted Aug 17, 2022 - 14:59 EDT
Investigating
Banner Faculty/Advising is currently experiencing an intermittent issue where some staff are not seeing the correct Dashboard. We are currently investigating this issue.
Posted Aug 17, 2022 - 12:09 EDT
This incident affected: Banner Self Service (Banner Faculty/Advising).