Email Delivery Issue - Microsoft365 Outlook
Incident Report for SCSU System Status
Resolved
This incident has been resolved.
Posted Aug 28, 2023 - 10:14 EDT
Update
All legitimate email messages that were in administrative hold were released by about 3PM today. There was likely some delay in the delivery due to the large number, but all should have been delivered by now. We are continuing to work with Microsoft to get root cause and measures to avoid future similar events.
Posted Aug 18, 2023 - 19:42 EDT
Monitoring
Microsoft began marking many messages from SCSU, especially those with a southernct.edu URL embedded in the body or signature of the message as "HIGH PHISHING" beginning around Tuesday of this week. "HIGH PHISHING" emails are automatically held in administrative quarantine due to the perceived danger.

We are investigating the issue with Microsoft with our highest priority channel.

In the meantime, emails that appear safe and wrongly marked are being released from administrative quarantine, and currently southernct.edu URLs are categorized back to "SAFE".

When the root cause is understood we will take every action to avoid similar events in the future.
Posted Aug 18, 2023 - 13:42 EDT