Help Desk - Unavailable 5/15/26, 11:30am - 1:30 pm

Incident Report for SCSU System Status

Resolved

The Help Desk is now back to normal operation.
Posted May 15, 2026 - 13:31 EDT

Identified

The IT Help Desk will not be able to immediate respond today, May 15, 2026 from 11:30 am - 1:30 pm, we will review your request as soon as we return. Thank you for your patience and understanding.
Posted May 15, 2026 - 11:21 EDT
This incident affected: IT Help Desk.