Banner Admin Pages
Incident Report for SCSU System Status
Resolved
This incident has been resolved.
Posted Feb 02, 2024 - 15:18 EST
Investigating
We are currently investigating an issue with Banner Admin pages timing out when you try to go to any page. Our vendor has been notified.
Posted Feb 02, 2024 - 09:03 EST
This incident affected: Banner Admin Pages.