Adobe Creative Cloud Login
Incident Report for SCSU System Status
Resolved
As of 12:04pm, Adobe announced all issues are resolved.
Posted Aug 22, 2023 - 12:22 EDT
Monitoring
From our internal testing, it looks like the Adobe Login issue has been resolved. We are continuing to monitor this development and will update this status page when the issue is confirmed to be completely resolved.
Posted Aug 22, 2023 - 11:25 EDT
Identified
Adobe has reported known Creative Cloud Login issues. When attempting to login to any Adobe desktop applications or Adobe web portal, users will get login errors or their login session will hang.

Adobe is working to resolve the issue. An update will be posted here once the issue has been resolved.
Posted Aug 22, 2023 - 09:38 EDT