Off Campus Calling Issue
Incident Report for SCSU System Status
Resolved
Confirmed the vendor has restored Service
Posted Jan 18, 2024 - 10:45 EST
Investigating
It appears that Windstream had an issue with their off campus calling. The duration of the outage was approx 25 minutes. We are investigating with Windstream the cause of the outage.
Posted Jan 18, 2024 - 10:21 EST
This incident affected: Telephone Systems.